↑ Return to WP-Slimbox2 Support

Object #<Object> has no method ‘slimbox’

Home Forums WP-Slimbox2 Support Object #<Object> has no method ‘slimbox’

This topic contains 0 replies, has 2 voices, and was last updated by  Malcalevak 5 years, 7 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1034

    Malcalevak
    Keymaster

    I recently updated to the latest version of Slimbox and now it doesn’t work. I get the following error in slimbox2_autoload on line 51 (prettified) รข?‚??€œ images.unbind(‘click’).slimbox(…:

    Uncaught TypeError: Object #<Object> has no method ‘slimbox’

    I can see that both slimbox scripts are loading and executing no problem. It seems like they’re working with different versions of jQuery. I can see the slimbox methods attaching to jQuery and jQuery.fn if I step through and in global scope right afterwards, but by the time we get to autoload jQuery no longer has them (and has a different expando attribute). But multiple versions of jQuery are not being loaded…I don’t think?

    Any chance you’d mind taking a look and seeing? http://mastomillers.com

    It’s been great for years, though, thank you!

    #1039

    Malcalevak
    Keymaster

    Hey there, did you manage to fix the issue on your own? I just visited and it seems to be working just fine.

    #1038

    trashsweeper
    Member

    Actually, I see that it works on the home page, but going into any post and trying the photo gallery there shows the problem.

    #1037

    Malcalevak
    Keymaster

    Ok, you’re right, when I go into a post the plugin stops working. I’m not really sure what’s the issue is, and I don’t have time to look into it in more detail tonight, but while looking over the source I noticed your comments section (which is only shown when you enter a post) is filled with a great deal of Javascript. I suspect that might be causing your problems.

    If it’s not too much hassle, could you try disabling the comment code long enough to test and see if it makes a difference?

    #1036

    trashsweeper
    Member

    I finally got around to this. I disabled the commenting plugin entirely (Disqus) and still have the same problem. Oy. Would sure appreciate any other insights you might have!

    #1035

    trashsweeper
    Member

    Never mind, found the conflicting plugin: LikeBot, which includes its own version of jQuery. Dirty!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

css.php